Name:Spitfire Image Stapler
 
Version:4.3.1.24
 
Publisher:Spitfire
 
The following prerequisites are required:
 
  • .NET Framework 3.5 (x861)
  • Windows Installer 3.1
If these components are already installed, you can launch the application now. Otherwise, click the button below to install the prerequisites and run the application.

1Windows x64 is supported, but this application will run in x32 mode

 
Install
 
Spitfire Customer Support    ::    ClickOnce and .NET Framework Resources